Vista gives “The folder you entered does not appear to be valid” connecting to WebDAV share

I run a Windows Home Server (WHS) for general file sharing and have an add-on which exposes some shares via WebDAV, this all works fine when accessing them under XP other than a certificate warning (my certs are self-signed and thus I have to OK it before proceeding).

However, under Vista when connecting by right-clicking in My Computer and doing “Add a Network Location” (rant – MS have really stuffed the UI for this) I input my URL – https://myserv.mansford.net/WebDav – I can verify this is correct as I can access it in Firefox & IE7. When clicking Next I get the error:

---------------------------
Add Network Location
---------------------------
The folder you entered does not appear to be valid.  Please choose another.
---------------------------
OK
---------------------------

The URL is valid and so there’s clearly an issue in Vista’s WebDAV client, anyway after much searching about I found a download for KB907306 – http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en

This makes the problem go away, I should note I had this issue in Vista Ultimate SP1, thus the update isn’t inside SP1 – helpful!

——– UPDATE ———
This no longer seems to resolve this issue, it certainly did once, but after rebooting I still can’t get on to the WebDAV share. This only affects Vista, I must percevere.

——– UPDATE 9 Mar 2008 ——–
Got fed up with  Vista (long story) and so have installed Windows Server 2008 on my Latitude D620 instead.  So far so good except I got exactly the same error. I searched about and ended up here.  This referred to Windows Server 2003 which led me back to the download for KB907306.  Immediately after installing this update (and without rebooting) it started working – I guess now I have to see if it stays that way!

Advertisements

4 responses to “Vista gives “The folder you entered does not appear to be valid” connecting to WebDAV share

  1. dude, thank you soooo much..saved me

  2. We were having this same problem with our Vista users (XP worked fine). I downloaded the KB907306 and tried all sorts of things but nothing worked. Finally, I figured out the problem was that we were using an in-house SSL certificate to secure traffic (https). As soon as I installed the root certificate of our organization, the problem went away. If you are having this problem, then make sure you have the organization’s root certificate installed or have the company (hosting the webdav folder) buy a trusted third-party certificate from Verisign, thawte, etc. The link below provides further info:
    http://sdb.open-xchange.com/node/83

    If nothing works, try downloading Netdrive (http://www.netdrive.net) which is free for home users and use that to connect to your webdav folder.

  3. Hannh Alex Xavier

    Thanks for your update. I installed KB907306 and the problem solved for me.

    Thanks again.

    Xavier

  4. I have the same issue as the above person:
    —————————
    Add Network Location
    —————————
    The folder you entered does not appear to be valid. Please choose another.
    —————————
    OK
    —————————

    And I tried everything that you all listed, net drive, and the update. I got nothing. Please help, this is so frustrating!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s